• Home
  • Features
  • Pricing
  • Docs
  • Announcements
  • Sign In

aio-libs / yarl / 36402958306
98%

Build:
DEFAULT BRANCH: master
Ran 28 Sep 2026 09:22AM UTC
Jobs 1
Files 40
Run time 1min
Badge
Embed ▾
README BADGES
x

If you need to use a raster PNG badge, change the '.svg' to '.png' in the link

Markdown

Textile

RDoc

HTML

Rst

28 Sep 2026 09:21AM UTC coverage: 97.68% (+0.2%) from 97.495%
36402958306

push

github

web-flow
Add RFC conformance test suite (#1922)

Cover RFC 3986 grammar, percent-encoding, normalization and reference
resolution, RFC 5952 IPv6 text forms, RFC 3987 IRI mapping, RFC 3492
punycode samples, IDNA2008 with UTS #46, legacy RFC 6874 zone IDs, and
the http, ws, file and mailto scheme RFCs. Known deviations are strict
xfails whose reason starts with 'yarl:'.

84 of 168 branches covered (50.0%)

Branch coverage included in aggregate %.

601 of 601 new or added lines in 5 files covered. (100.0%)

7833 of 7937 relevant lines covered (98.69%)

0.99 hits per line

Jobs
ID Job ID Ran Files Coverage
1 MyPy - 36402958306.1 28 Sep 2026 09:22AM UTC 40
97.68
GitHub Action Run
Source Files on build 36402958306
  • Tree
  • List 40
  • Changed 0
  • Source Changed 0
  • Coverage Changed 0
Coverage ∆ File Lines Relevant Covered Missed Hits/Line Branch Hits Branch Misses
  • Back to Repo
  • Github Actions Build #36402958306
  • 61cee462 on github
  • Prev Build on master (#36400545392)
  • Next Build on master (#36409150614)
  • Delete
STATUS · Troubleshooting · Open an Issue · Sales · Support · CAREERS · ENTERPRISE · START FREE TRIAL · SCHEDULE DEMO
ANNOUNCEMENTS · TWITTER · TOS & SLA · Supported CI Services · What's a CI service? · Automated Testing

© 2026 Coveralls, Inc