Ran
|
Jobs
1
|
Files
3
|
Run time
1s
|
Badge
Embed ▾
README BADGES
|
push
github
Rename `requiredPrefund` to `missingAccountFunds` (#124) This PR applies a minor suggestion resulting from the audit where the `validateUserOp` parameter names (specifically for the required account fund transfer to the entrypoint) did not exactly match the name from the ERC. Note that the test entrypoint was slightly adjusted to more closely model the behaviour of the [reference entrypoint](https://github.com/eth-infinitism/account-abstraction/blob/94cf025ef/contracts/core/EntryPoint.sol#L421-L427), where left-over user balances are considered when computing the `missingAccountFunds` to pass into the `validateUserOp` call: ```solidity uint256 missingAccountFunds = 0; if (paymaster == address(0)) { uint256 bal = balanceOf(sender); missingAccountFunds = bal > requiredPrefund ? 0 : requiredPrefund - bal; } ``` I noticed this while looking for instances of `requiredPrefund` in the codebase. All tests continue to pass 🎉. Another minor change, I noticed that `prettier .` was not picking up `.sol` files anymore, so I adjusted the NPM scripts to explicitly format and check them.
18 of 18 branches covered (100.0%)
Branch coverage included in aggregate %.
2 of 2 new or added lines in 1 file covered. (100.0%)
26 of 26 relevant lines covered (100.0%)
13.46 hits per line
ID | Job ID | Ran | Files | Coverage | |
---|---|---|---|---|---|
1 | 6721220570.1 | 3 |
100.0 |
GitHub Action Run |
Coverage | ∆ | File | Lines | Relevant | Covered | Missed | Hits/Line | Branch Hits | Branch Misses |
---|